Issue Opening PDF, Markdown, and Custom Components in Multimodal Project

Incident Report for SuperAnnotate AI

Postmortem

During the recent release, an issue occurred in the CDN distribution that serves external frontend libraries. As a result, requests to load certain static assets (e.g., pdfjs-express/8.7.2/webviewer.min.js) returned 504 Gateway Timeout errors.

Because several components (PDF, Markdown and other custom components) depend on externally hosted CDN assets at runtime, the failure to load these scripts caused those components from initializing or functioning correctly.

The root-cause was not related to component logic itself, but by the unavailability of required CDN resources during application initialization.

Posted May 07, 2026 - 10:27 UTC

Resolved

The issue is confirmed to be resolved.
Posted May 07, 2026 - 09:09 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 07, 2026 - 09:09 UTC

Identified

The issue has been identified and fix is being implemented.
Posted May 07, 2026 - 07:45 UTC

Investigating

We’re currently experiencing issues opening items with PDF, Markdown, and some custom components in the Multimodal project. We’re investigating the problem and working on a fix.
Posted May 07, 2026 - 07:30 UTC
This incident affected: SuperAnnotate Editors.