Invitation Emails Not Being Sent

Incident Report for SuperAnnotate AI

Resolved

Service has been restored and is operating normally. We are continuing to investigate the root cause and assess the overall impact.
Posted Mar 26, 2026 - 09:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 09:21 UTC

Identified

Our team has identified the issue and is actively working with Amazon Web Services, our email service provider, to resolve it.
Posted Mar 26, 2026 - 09:10 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2026 - 08:35 UTC

Investigating

Invitation emails from the platform are not being delivered. The issue is currently under investigation.
Posted Mar 26, 2026 - 08:25 UTC
This incident affected: SuperAnnotate Web Platform.