Increased Job Failures in Orchestrate

Incident Report for SuperAnnotate AI

Resolved

The Kubernetes network issue has been fixed, and job processing is back to normal.
Posted Mar 26, 2026 - 13:20 UTC

Identified

Following the recent release, we observed an increase in failed jobs within Orchestrate. This was caused by a Kubernetes network issue that led to intermittent disruptions during job execution.
Posted Mar 26, 2026 - 11:00 UTC
This incident affected: SuperAnnotate Web Platform.